BYOK-enabled Tableflow deployments may experience data inconsistencies when executing queries that include filter predicates

Incident Report for Confluent Cloud

Resolved

This incident has been resolved.
Posted Nov 28, 2025 - 18:33 UTC

Update

We have fixed the issue, and are now monitoring the few affected tables to ensure they all return to full operation. As of Nov 28th 6:00PM UTC customers should see normal operations with Confluent systems.
Posted Nov 28, 2025 - 18:02 UTC

Identified

We've identified the issue; a hotfix is on its way to production.
Posted Nov 28, 2025 - 13:25 UTC
This incident affected: Confluent Cloud.