Elevated error rates in AWS me-south-1 and me-central-1 regions

Incident Report for Confluent Cloud

Update

Per AWS, the me-south-1 region is now completely unavailable. Customers will not be able to access clusters in the me-south-1 region. Customers who have workloads in me-central-1 are strongly advised to relocate them to an alternative region.
Posted Apr 02, 2026 - 15:40 UTC

Update

Provisioning new workloads in AWS me-central-1 and me-south-1 regions is disabled. Migration steps to other AWS regions have been communicated to impacted customers.
Posted Apr 01, 2026 - 19:52 UTC

Monitoring

AWS regional recovery is expected to be extended in both me-central-1 and me-south-1 regions. Customers requiring immediate restoration in these two regions are encouraged to review regional failover options.
Posted Mar 20, 2026 - 13:58 UTC
This incident affects: Confluent Cloud.