All new dedicated kafka cluster provisioning and expansion in Azure westus3, southcentralus, and eastus2 are failing

Incident Report for Confluent Cloud

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 01:57 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 26, 2026 - 23:07 UTC

Investigating

Azure is investigating the issue and we will post an update soon.
Posted Feb 26, 2026 - 19:56 UTC
This incident affected: Confluent Cloud.