Delays in Provisioning affecting Schema Registry, KSQL and Stream Governance resources

Incident Report for Confluent Cloud

Resolved

This incident has been fully resolved.
Posted Oct 04, 2025 - 15:46 UTC

Monitoring

Provisioning times have returned to normal since the last update and a mitigation has been put in place to prevent further regressions. Confluent will continue to monitoring to ensure that the issues have been resolved.
Posted Oct 03, 2025 - 18:26 UTC

Update

Provisioning Performance Restored

Provisioning times for Schema Registry, KSQL, and Stream Governance resources have returned to normal. Our engineering team is continuing to investigate the root cause to ensure long-term stability.
Posted Oct 03, 2025 - 08:27 UTC

Investigating

We are currently experiencing degraded performance in the provisioning flow for Schema Registry, KSQL, and Stream Governance resources.
Impact: Newly created clusters and API keys for these services may be delayed. You may also encounter authentication/authorization errors when using newly created keys.
Unaffected: Existing clusters, keys, and resources continue to function as expected.
Our engineering team is actively investigating and working to restore normal provisioning times. We will provide updates as more information becomes available.
Posted Oct 03, 2025 - 04:43 UTC
This incident affected: Confluent Cloud.