Elevated Kafka Latency in GCP asia-southeast1

Incident Report for Confluent Cloud

Resolved

The issue was resolved successfully. All systems working as expected.
Posted Feb 24, 2026 - 09:58 UTC

Monitoring

GCP has identified the root cause and has fixed the same. Currently monitoring.
Posted Feb 24, 2026 - 07:27 UTC

Update

We are continuing to investigate this issue with GCP. GCP is actively working on applying mitigation.
Posted Feb 24, 2026 - 00:23 UTC

Update

We are continuing to investigate this issue.
Posted Feb 23, 2026 - 22:18 UTC

Update

Starting 2/21/2026, 21:00 UTC We are observing Elevated Kafka Latency in GCP asia-southeast1 region for less than 0.1% of produce and fetch requests for some customers. Median latencies for both produce and fetch requests are not impacted. We are actively working with GCP to identify the root cause of the issue. We will provide next update in 2 hours or earlier.
Posted Feb 23, 2026 - 22:17 UTC

Investigating

We are currently investigating this issue.
Posted Feb 23, 2026 - 22:12 UTC
This incident affected: Confluent Cloud.