Customers are encountering a 404 error when attempting to access resources within the Confluent Cloud UI.

Incident Report for Confluent Cloud

Resolved

This incident has been resolved.
Posted Oct 27, 2025 - 18:13 UTC

Update

We are currently investigating the issue. In the meantime, customers can use the CLI to manage the resources.
Posted Oct 27, 2025 - 17:56 UTC

Investigating

We are currently investigating the root cause.
Posted Oct 27, 2025 - 17:48 UTC
This incident affected: Confluent Cloud.