Confluent Cloud Console Degraded (All Regions) and Multiple Services Impacted in AWS us-west-2

Incident Report for Confluent Cloud

Monitoring

All affected services, including Flink in AWS us-west-2, have recovered and we are no longer observing customer impact. We are monitoring to confirm full stability before resolving this incident.
Posted Sep 23, 2026 - 15:57 UTC

Update

Flink in AWS us-west-2 is continues to be affected while we restore full service: running jobs may remain degraded and new job submissions may continue to fail during this period.

All other services including Connect, ConfluentCloud UI are mitigated and operational
Posted Sep 23, 2026 - 14:18 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 23, 2026 - 11:47 UTC
This incident affects: Confluent Cloud.