Cluster provisioning delayed in AWS

Incident Report for Confluent Cloud

Resolved

This incident has been resolved.
Posted Oct 08, 2025 - 07:59 UTC

Monitoring

The deployment is now complete and the AWS cluster provisioning delays have been mitigated as of 03:20 UTC on Oct 7, 2025. We will monitor for any residual issues before resolving this incident in 1 hour.
Posted Oct 08, 2025 - 03:20 UTC

Update

A fleet-wide deployment containing a permanent fix is underway. We are continuing to monitor the rollout and will update when it is complete.
Posted Oct 07, 2025 - 19:46 UTC

Identified

We have identified the root cause as a failure in the underlying disk-mounting mechanism, which has required manual intervention. The impacted nodes have been fixed, and we are preparing to roll out a permanent fix.
Posted Oct 06, 2025 - 21:37 UTC

Investigating

We are currently experiencing delays in cluster provisioning in AWS. The team is currently investigating.
Posted Oct 06, 2025 - 19:24 UTC
This incident affected: Confluent Cloud.