Google Cloud Platform Outage Affecting Multiple Confluent Cloud Services

Incident Report for Confluent Cloud

Resolved

All Confluent Cloud systems have recovered and the issues have been resolved. All operations should work normally as expected.
Posted Jun 12, 2025 - 22:14 UTC

Monitoring

As of now Google Cloud Platform (GCP) has recovered in all regions except for us-central1. We are seeing that data plane operations (reads and writes to Kafka clusters) have recovered in all regions except for us-central1. In addition, Flink statements on GCP that are not in us-central1 have recovered. We are still seeing issues with control plane operations (resource provisioning and cluster link creation). We are continuing to monitor the situation and will provide an update as soon as more information becomes available.
Posted Jun 12, 2025 - 20:52 UTC

Investigating

We are currently experiencing a global outage with Google Cloud Platform (GCP), which is affecting multiple Confluent Cloud services. Customers may observe:
• Delays or failures when provisioning new resources
• Issues creating cluster links between privately networked clusters
• Failures or degraded performance for Connect connectors hosted on GCP
• Inability to access historical data from Kafka clusters on GCP
• Intermittent Read and Write failures on impacted clusters on GCP
• Flink statements on GCP are currently unable to make progress and produce output

Our engineering teams are actively monitoring the situation and working with GCP to assess the full scope and mitigate the impact.

Next Update: We will provide an update as soon as new information becomes available.

For more information on the GCP outage, please refer to https://status.cloud.google.com/.
Posted Jun 12, 2025 - 18:58 UTC
This incident affected: Confluent Cloud.