The Confluent Cloud UI homepage should now be visible, showing the summary of environments/clusters for most customers. Newer organizations created in the last three days may still not be showing correct summaries. The Confluent team expects to have the issue fully resolved for these remaining organizations by May 12 11:00 PM UTC.
Posted May 12, 2025 - 21:22 UTC
Monitoring
The Confluent Cloud UI homepage should now be visible, showing the summary of environments/clusters for most customers. Newer organizations created in the last three days may still not be showing correct summaries. The Confluent team is aware, monitoring the change and the situation.
Posted May 12, 2025 - 19:41 UTC
Investigating
The Confluent Cloud UI homepage is in a degraded state and is currently unable to properly show the summary of environments/clusters. The underlying health of environments/clusters is unaffected. The team is working on a fix.