Elevated error rates and latencies in Azure westus2 region

Incident Report for Confluent Cloud

Monitoring

We are monitoring the health of impacted Confluent services in the Azure West US2 region. More details about the Multi Service degradation on the Azure status page: https://azure.status.microsoft/en-us/status
Posted May 29, 2026 - 10:25 UTC

Update

Confluent cloud services are experiencing outage in Azure West US2 region linked to Azure network connectivity degradation.
Team is continuing active investigation.
Posted May 29, 2026 - 06:47 UTC

Investigating

We are currently experiencing increased error rates and latencies in the Azure westus2 region. This began at approximately 5:10 AM UTC 29th May. Our team is actively investigating it.
Posted May 29, 2026 - 05:57 UTC
This incident affects: Confluent Cloud.