Confluent Cloud — Degraded inter-region connectivity — AWS us-west-2

Incident Report for Confluent Cloud

Resolved

This incident has been resolved.
Posted Jun 12, 2026 - 11:55 UTC

Monitoring

We have deployed a mitigation for the intermittent inter-region connectivity issues affecting AWS us-west-2, which began at approximately 04:00 UTC. Customers with clusters in or communicating with this region may have experienced delays or errors with Cluster Linking, Flink processing, and accessing logs in the Confluent Cloud UI. We are monitoring to confirm full restoration.
Posted Jun 12, 2026 - 09:53 UTC

Update

We continue to investigate intermittent inter-region network connectivity issues affecting AWS us-west-2. Customers may experience delays or errors with Cluster Linking, Flink processing and logs for clusters in or communicating with this region. We are actively investigating the cause and working on mitigation.
Posted Jun 12, 2026 - 09:11 UTC

Investigating

We are investigating intermittent inter-region network connectivity issues affecting AWS us-west-2. Customers may experience delays or errors with Cluster Linking and Apache Flink processing for clusters in or communicating with this region. We are actively investigating the cause and working on mitigation.
Posted Jun 12, 2026 - 07:42 UTC
This incident affected: Confluent Cloud.