Degraded Kafka performance affecting some Confluent Cloud clusters

Incident Report for Confluent Cloud

Resolved

This incident has been resolved.
Posted Sep 08, 2025 - 17:49 UTC

Update

Issues related to internal topic compaction have been resolved.
Posted Sep 08, 2025 - 17:47 UTC

Monitoring

We have deployed mitigation steps. We'll continue monitoring but no longer expect any customer impact.
Posted Sep 04, 2025 - 17:05 UTC

Update

Mitigation is in progress. Next update in 2 hours.
Posted Sep 04, 2025 - 14:58 UTC

Update

Mitigation is still in progress. Next update in 3 hours
Posted Sep 04, 2025 - 12:43 UTC

Identified

We are experiencing issues related to internal topic compaction causing topic size to grow. This is impacting cluster performance in a limited number of clusters with extreme cases. We have identified the root cause and are actively working on a fix. Next update soon.
Posted Sep 04, 2025 - 09:42 UTC
This incident affected: Confluent Cloud.