Delays in provisioning Kafka clusters in Confluent Cloud

Incident Report for Confluent Cloud

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 18:30 UTC

Identified

Customers may experience delays in provisioning new Kafka clusters in Confluent Cloud. Confluent engineering has identified the root cause and is working on the fix.
Posted Mar 25, 2025 - 18:13 UTC
This incident affected: Confluent Cloud.