Issues observed with Azure Europe West are now resolved. Most impacted services have recovered and are operational. We are working on resolving issues impacting performance for few customers.
Posted Nov 06, 2025 - 14:03 UTC
Update
We are monitoring Azure updates and recovery closely. We are noticing partial recovery in a subset of affected resources and will provide an update as more information becomes available.
Posted Nov 06, 2025 - 01:48 UTC
Update
Azure has provided an update on it's Status Page (https://azure.status.microsoft/en-us/status) stating that recovery efforts are in progress. We will provide an update within 60 minutes.
Posted Nov 05, 2025 - 22:29 UTC
Update
Azure posted outage details on its status page: https://azure.status.microsoft/en-us/status. No material changes since last update. We continue monitoring the situation from our side and will provide the next update within 60 minutes or when the status changes.
Posted Nov 05, 2025 - 21:13 UTC
Identified
The issue was localized to a single Availability Zone in Azure West Europe region. Only Single Zone Kafka Clusters are affected at this time. Multi-Zone clusters experienced intermittent availability and elevated latency for produce and fetch requests but auto-recovered within minutes. We are continuing to work with Microsoft Azure for resolution of affected single zone clusters. We will post next update by 1:00 PST.
Posted Nov 05, 2025 - 19:51 UTC
Update
We are continuing to investigate this issue.
Posted Nov 05, 2025 - 19:22 UTC
Update
We are beginning to see some recovery of the affected Kafka clusters.
Posted Nov 05, 2025 - 18:47 UTC
Investigating
We are currently experiencing an issue that appears to be related to an ongoing incident with Microsoft Azure. We are actively working with the Azure team to confirm the impact and will provide updates as soon as more information becomes available.