Scheduled Confluent Cloud maintenance on May 6, 2026

Incident Report for Confluent Cloud

Resolved

The maintenance is complete.
Posted May 07, 2026 - 03:08 UTC

Monitoring

Confluent Cloud is undergoing a planned maintenance event between 4pm and 8pm PST on May 6, 2026. Customers might experience intermittent unavailability of certain pages in the customer portal, such as new customer sign-up, cluster creation, promo code claims, invoicing and public cost interfaces.
Posted May 06, 2026 - 22:12 UTC
This incident affected: Confluent Cloud.