Kafka role binding write operations are slow to propagate to Confluent Cloud Kafka clusters

Incident Report for Confluent Cloud

Resolved

The role binding propagation performance is back to normal
Posted 7 months ago. Sep 11, 2024 - 10:57 UTC

Update

We are observing improved latency across most partitions. We are monitoring a few partitions with lag. We will provide another update within 30 minutes
Posted 7 months ago. Sep 11, 2024 - 10:49 UTC

Monitoring

We have been monitoring the progress of the fix for the past hour and are noticing improvement in overall role binding propagation latency. We will provide another update in 30 minutes
Posted 7 months ago. Sep 11, 2024 - 10:01 UTC

Identified

At 8:15 UTC we have noticed a degradation in the performance of role-binding write operations materializing on Kafka clusters. This can also affect the provisioning of new clusters - they might remain inaccessible until the role-binding changes propagate. We have deployed a fix at 9:00UTC and are monitoring the delay.
Posted 7 months ago. Sep 11, 2024 - 09:05 UTC
This incident affected: Confluent Cloud.