No further issues have been observed. The incident is now resolved as of 2025-1203 02:03 UTC.
Posted Dec 03, 2025 - 02:04 UTC
Monitoring
A fix has been applied to all regions and we've seen recovery in all affected regions. We'll continue to monitor for the next 30 minutes.
Posted Dec 03, 2025 - 01:32 UTC
Update
The team has successfully applied a fix to asia-northeast1 and we're seeing recovery there. Meanwhile the team is applying mitigations in the other affected regions.
Posted Dec 02, 2025 - 23:14 UTC
Identified
The root cause for the issue has been identified and the team is working on applying a mitigation.
Posted Dec 02, 2025 - 22:03 UTC
Investigating
This manifests itself in new Flink jobs remaining stuck in "Statement Status: Pending", existing Flink jobs being requested to stop remaining stuck in "Statement Status: Stopping". This issue started manifesting at 2025-12-02 19:53 UTC.
We are currently investigating the issue and attempting to mitigate or provide a work-around.