Flink Statements Restarted
Incident Report for Confluent Cloud
Resolved
This incident has been resolved. As of 20:40 UTC on May 1st, 2024, customers should see normal operations with Confluent systems.
Posted May 01, 2024 - 21:59 UTC
Monitoring
All impacted statements, which were incorrectly marked as DELETING are fixed now as of 20:40 UTC on May 1st, 2024. We will monitor for any issues before resolving this incident in 1 hour.
Posted May 01, 2024 - 21:01 UTC
Update
We are continuing to mitigate this issue.

We have mitigated most of the impacted statements, which were incorrectly marked as DELETING. Mitigation for the remaining impacted statements is in progress.
Posted May 01, 2024 - 17:08 UTC
Update
We are continuing to mitigate this issue.

The affected Flink Statements, which were previously restarted, have now been stopped. The process of mitigating the impacted statements, which are marked as DELETING but are still operational, is underway.
Posted Apr 30, 2024 - 23:54 UTC
Identified
The issue has been identified and mitigation is in progress.

Some of the impacted statements may show as DELETING but are still running.
Posted Apr 30, 2024 - 18:30 UTC
Investigating
We are observing some Flink Statements in COMPLETED or RUNNING mode have been restarted from initial offsets without taking into account previous state around 2024-04-29 20:00 UTC.
Posted Apr 30, 2024 - 15:49 UTC
This incident affected: Confluent Cloud.