Some customers using Confluent Cloud Flink on Azure with PrivateLink connectivity are experiencing issues submitting new Flink statements

Incident Report for Confluent Cloud

Resolved

This incident has been resolved.
Posted Apr 25, 2026 - 00:14 UTC

Monitoring

A fix has been implemented and we are monitoring for next hour.
Posted Apr 24, 2026 - 23:06 UTC

Update

Roll out of fix is progressing, expecting all clusters to complete in approximately 30 minutes.
Posted Apr 24, 2026 - 22:27 UTC

Identified

The issue has been identified and fix is being rolled out. ETA for rollout complete across impacted regions 2 hours.
Posted Apr 24, 2026 - 20:14 UTC

Investigating

We are currently investigating this issue.
Posted Apr 24, 2026 - 17:18 UTC
This incident affected: Confluent Cloud.