Delayed cluster provisioning in Azure eastus region

Incident Report for Confluent Cloud

Resolved

This incident has been resolved.
Posted Oct 25, 2025 - 05:14 UTC

Update

Dedicated private networks and dedicated Kafka clusters provisioning with PrivateLink or VNet Peering are unavailable in the Azure eastus region.
Posted Oct 24, 2025 - 17:05 UTC

Update

Provisioning delays have been partially mitigated, but there may still be delays for eastus region.
Posted Oct 23, 2025 - 23:56 UTC

Update

We've identified a mitigation method and are rolling this out across affected networks.
Posted Oct 23, 2025 - 20:17 UTC

Identified

We are experiencing provisioning delays in Azure eastus region.
Posted Oct 22, 2025 - 22:38 UTC
This incident affected: Confluent Cloud.