Flink APIs to fetch regions and compute pools are impacted globally

Incident Report for Confluent Cloud

Resolved

The incident has been resolved and APIs are functioning correctly.
Posted Jul 07, 2025 - 20:47 UTC

Monitoring

Starting Jul 7, approximately 17:39 UTC, Flink APIs to fetch regions and compute pools encountered failures.
The issue was mitigated approximately Jul 7, 18:25 UTC and Confluent is actively monitoring the status.
Posted Jul 07, 2025 - 18:58 UTC