Azure Private Endpoint to Confluent Private Link Creation Failures
Incident Report for Confluent Cloud
Resolved
As of 5pm Pacific, Azure has finished applying the fix to the previously-mentioned four regions. At this point, all Azure regions that Confluent services are in working order.
Posted Sep 18, 2021 - 00:26 UTC
Update
Azure regions with Confluent customers are currently functional, however, there are some regions supported by Confluent where Azure is still working to restore functionality by September 29th. These are: FranceCentral, GermanyWestCentral, JapanEast, and SouthAfricaNorth. If you are running a cluster in one of these regions and still experiencing difficulties, please contact our customer service for a manual work-around.
Posted Sep 17, 2021 - 19:53 UTC
Update
All regions except NorthEurope have been verified by Confluent engineers as functional again. We will continue working with Azure support to get this final region's functionality restored.
Posted Sep 17, 2021 - 16:21 UTC
Monitoring
Azure has fixed the problems in all affected regions as of 7am Friday September 17th, Pacific Time. We are checking all API calls to be sure the fixes are functional.
Posted Sep 17, 2021 - 15:29 UTC
Update
We have narrowed down the scope of the problem: customers are unable to create Azure Private Endpoints to Confluent Cloud Private Link using Service Aliases. If you are currently blocked on this problem, contact our Customer Support team, as we do have a work-around that we can provide. Azure expects to have this issue resolved today, Thursday September 16th.
Posted Sep 16, 2021 - 16:00 UTC
Identified
We are receiving reports that customers cannot create Private Links in Azure. The problems started around 2am today, and continue intermittently. The limitation may occur in multiple Azure regions. We are working with Azure support to troubleshoot and implement a fix, and will update as we know more.
Posted Sep 16, 2021 - 03:53 UTC
This incident affected: Confluent Cloud.