Microsoft reports Azure status as fully operational. The incident is now resolved as of 0:40 UTC on Oct 29th, 2025.
Posted Oct 30, 2025 - 00:42 UTC
Update
Flink statements in Azure have recovered following Microsoft’s rollback of a recent network configuration change. Confluent systems are fully operational at this time, though Microsoft is continuing to monitor the rollback and validate stability. We will remain in monitoring until Microsoft confirms full recovery.
Posted Oct 29, 2025 - 20:35 UTC
Monitoring
Microsoft has indicated they have completed rolling back the network configuration change. Degraded Flink statements have begun recovering.
Posted Oct 29, 2025 - 18:59 UTC
Identified
Confluent has confirmed that Flink statements running in Azure are currently degraded. Microsoft is actively working to roll back the configuration change.
Posted Oct 29, 2025 - 18:39 UTC
Update
We are continuing to investigate this issue.
Posted Oct 29, 2025 - 18:12 UTC
Investigating
Confluent engineers are engaged on the incident. The impact is related to the ongoing Azure incident. You can find more information here: https://azure.status.microsoft/en-us/status