IP changes in eu-central-1 Single Zone Confluent Cloud Professional cluster
Incident Report for Confluent Cloud
Resolved
Maintenance has finished with no incidents.
Posted Aug 13, 2020 - 08:35 CDT
Monitoring
We are performing some routinary maintenance on the CCP cluster Single Zone pkc-l6y8e.eu-central-1.aws.confluent.cloud, which requires the change of the IPs for all brokers.

IP address changes are a part of the business as usual activities of hosted services, and can be expected to occur periodically. See https://docs.confluent.io/current/cloud/faq.html#are-ccloud-ip-addresses-static

But we detected a higher delay than expected of traffic coming back to normal, which might be caused by some clients unable to reconnect, for instance due some DNS caching.

Ensure that your applications are configured correctly to avoid any impact. Specifically:

- Do not cache DNS entries within the Operating System.
- Do not use restrictive firewalls to allow only the specific IPs that are currently associated with your Confluent Cloud Clusters.
- Ensure that configuration for Java clients follow these recommendations to not cache DNS entries within the Java Virtual Machine.
- Ensure any other clients that are not Confluent supported are configured to not cache DNS entries
Posted Aug 13, 2020 - 06:14 CDT
This incident affected: AWS (eu-central-1).